Useful Dell OS9 Commands and their Cisco equivalent

So, my background in networking has been largely Cisco Technology, and since starting here at ComputerWorld, I have been introduced to Dell Networking and have been learning the differences between Cisco and Dell. So, I thought it was right that in my first blog for ComputerWorld I write about some of the useful CLI commands on Dell’s OS9 (S & Z series) switch OS that I have picked up in my time here at ComputerWorld and how they compare to the Cisco IOS commands that people might be more familiar with.

One of the first things any network engineer needs to do is configure an interface as an access port on a certain VLAN.  Dell OS9 has taken a slightly different approach to achieve this. So, in the next section, I will go through setting up an interface as an access port and then how to make it a trunk. In this example, I will use VLAN 100.

The first thing we must do is create the VLAN.

Cisco

Test-cisco#configure terminal
Test-cisco(config)#vlan 100
Test-cisco(config-vlan)#name Test-Vlan
Test-cisco(config-vlan)#end
Test-cisco#show Vlans

VLAN Name               Status    Ports
---- ------------------------- --------- --------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gig0/1, Gig0/2
100  Test-Vlan                        active    
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup
Test-cisco#

Dell OS9

Test-dell#configure terminal
Test-dell(conf) #interface vlan 100
Test-dell(conf) #description Test-Vlan
Test-dell(conf) #end
Test-dell#show vlan

Codes: * - Default VLAN, G - GVRP VLANs, R - Remote Port Mirroring VLANs, P - Primary, C - Community, I - Isolated
       O - Openflow, Vx - Vxlan
Q: U - Untagged, T - Tagged
   x - Dot1x untagged, X - Dot1x tagged
   o - OpenFlow untagged, O - OpenFlow tagged
   G - GVRP tagged, M - Vlan-stack
   i - Internal untagged, I - Internal tagged, v - VLT untagged, V - VLT tagged

    NUM    Status    Description                     Q Ports
*   1      Inactive                                  
                                                     
    100    Inactive  Test-VLAN                                

As you can see creating VLANs on Dell OS9 and Cisco are very similar, and if you know the commands for one, the other will be easy to pick up.

The next step will be to assign the VLAN to the port or as dell does it assign the interface to the VLAN.

Cisco

Test-cisco#configure terminal
Test-cisco(config)#interface FastEthernet 0/1
Test-cisco(config-if)#switchport mode access
Test-cisco(config-if)#switchport access vlan 100
Test-cisco(config-if)#end
Test-cisco#show running-config interface FastEthernet 0/1
interface FastEthernet0/1
 switchport access vlan 100
 switchport mode access

In Cisco IOS we set the port to be an access interface and then with assign VLAN 100 to that interface under the interface.

Dell OS9

Test-dell#configure terminal
Test-dell(conf) #interface TenGigabitEthernet 1/2
Test-dell(conf-if-te-1/2)#switchport
Test-dell(conf-if-te-1/2)#no shutdown
Test-dell(conf-if-te-1/2)#exit
Test-dell(conf) #interface vlan 100
Test-dell(conf-if-vl-100)# untagged tengigabitethernet ½
Test-dell(conf) #end
Test-dell#show vlan

Codes: * - Default VLAN, G - GVRP VLANs, R - Remote Port Mirroring VLANs, P - Primary, C - Community, I - Isolated
       O - Openflow, Vx - Vxlan
Q: U - Untagged, T - Tagged
   x - Dot1x untagged, X - Dot1x tagged
   o - OpenFlow untagged, O - OpenFlow tagged
   G - GVRP tagged, M - Vlan-stack
   i - Internal untagged, I - Internal tagged, v - VLT untagged, V - VLT tagged

    NUM    Status    Description                     Q Ports
*   1      Inactive                                  
                                                     
    100    Inactive  Test-VLAN                       U  Te1/2         

Unlike Cisco IOS you must set the interface to a switchport then under the VLAN set the interface to untagged. This is a different approach to how you assign VLANs to interfaces. It is like the way HP handles VLAN assignment.  You will also notice that we had to do the command no shutdown on the interface. This is because on OS9 all ports are shutdown by default whereas Cisco they are all un-shut on their switches.

The key networking ideological difference between Cisco IOS and Dell Networking is that on Cisco a trunk port passes all the VLANs on that switch by default and you will then have to restrict the port if you need to restrict VLANs passing on a trunk port. The Dell approach is that this inherently insecure as you can by mistake have VLANs traversing your network that don’t need too and potentially add unnecessary congestion on the network. So, with Dell’s VLAN first approach you have to specify on each VLAN each interface you want to be allowed on that trunk port. It is a longer process config a trunk but a more secure approach than Cisco’s. As you must specify which VLANs are on the interface rather then cisco passing all VLANs by default.    

In the next section, I will through another fundamental function for a network engineer, creating a Trunk port on both Cisco and Dell OS9

Cisco

Test-cisco#configure terminal
Test-cisco(config)#interface FastEthernet 0/1
Test-cisco(config-if)#switchport trunk encapsulation dot1q
Test-cisco(config-if)#switchport mode trunk
Test-cisco(config-if)#end
Test-cisco#show running-config interface FastEthernet 0/1
interface FastEthernet0/1
 switchport trunk encapsulation.
 switchport mode trunk

You then add in the command switchport trunk allowed VLAN  to lock down the trunk interface to only VLAN 1, and 100 passing through this interface.

Test-cisco#configure terminal
Test-cisco(config)#interface FastEthernet 0/1
Test-cisco(config-if)#switchport trunk allowed vlan 100
Test-cisco(config-if)#end
Test-cisco#show running-config interface FastEthernet 0/1
interface FastEthernet0/1
 switchport trunk allowed vlan 100
 switchport trunk encapsulation.
 switchport mode trunk

Dell

Test-dell#configure terminal
Test-dell(conf) #interface TenGigabitEthernet 1/2
Test-dell(conf-if-te-1/2)#switchport
Test-dell(conf-if-te-1/2)#no shutdown
Test-dell(conf-if-te-1/2)#exit
Test-dell(conf) #interface vlan 100
Test-dell(conf-if-vl-100)# tagged tengigabitethernet ½
Test-dell(conf) #end
Test-dell#show vlan

Codes: * - Default VLAN, G - GVRP VLANs, R - Remote Port Mirroring VLANs, P - Primary, C - Community, I - Isolated
       O - Openflow, Vx - Vxlan
Q: U - Untagged, T - Tagged
   x - Dot1x untagged, X - Dot1x tagged
   o - OpenFlow untagged, O - OpenFlow tagged
   G - GVRP tagged, M - Vlan-stack
   i - Internal untagged, I - Internal tagged, v - VLT untagged, V - VLT tagged

    NUM    Status    Description                     Q Ports
*   1      Inactive                                  
                                                     
    100    Inactive  Test-VLAN                       T  Te1/2         

On Dell OS9 you will create a trunk with the following commands

The next and final commands I will talk about is configuring Spanning tree and the different show commands needed to check that your Spanning tree configuration.

Cisco

Test-cisco# Switch#show spanning-tree summary 
Switch is in pvst mode
Root bridge for:
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is disabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

---------------------- -------- --------- -------- ---------- ----------
2 vlans                      0         0        0          0          0

The show spanning-tree summary command shows you on Cisco what version of spanning tree is running on the switch. By Default Cisco runs PVST (Per VLAN Spanning tree) and it is switched on. Dell by default does not run any form of spanning-tree. This is a very important thing to notice, and when configuring OS9, you must enable some form of Spanning tree. The following is the show commands for the dell.

Test-dell#show spanning-tree pvst
VLAN 1
Root Identifier has priority 32768, Address e4f0.0490.16a7
Root Bridge hello time 2, max age 20, forward delay 15
Bridge Identifier has priority 32768, Address e4f0.0490.16a7
Configured hello time 2, max age 20, forward delay 15
We are the root of VLAN 1
Current root has priority 32768, Address e4f0.0490.16a7
Number of topology changes 0, last change occured 00:27:36 ago on
VLAN 100
Root Identifier has priority 32768, Address e4f0.0490.16a7
Root Bridge hello time 2, max age 20, forward delay 15
Bridge Identifier has priority 32768, Address e4f0.0490.16a7
Configured hello time 2, max age 20, forward delay 15
We are the root of VLAN 100
Current root has priority 32768, Address e4f0.0490.16a7
Number of topology changes 0, last change occured 00:27:45 ago on

If you run this command and it does not return anything, then PVST is not running and needs enabling. I will next show how to enable PVST on both Cisco and Dell to illustrate the difference between them.

Test-cisco#configure terminal
Test-cisco(config)#spanning-tree mode pvst

On the Dell it is 

Test-dell#configure terminal
Test-dell(conf) #protocol spanning-tree pvst
Test-dell(conf-pvst)no disable

The key thing for me to remember when configuring spanning tree on the Dells is the command “protocol” before spanning tree.  It took me a little reading to find this command.

In summary, the key differences between Dell and Cisco are the approach they take to where the untagging and tagging happens (Cisco: interface, Dell: VLAN), how the trunks allow VLANs and how dell OS9 does not have any form of Spanning tree by default. But other than that the CLI commands are very similar and any engineer familiar with Cisco will no problem using Dell OS9.

If you would like any more information, why not speak to our networking specialist or visit our Networking solutions page?!